ЕГЭ Справочник
Информатика и ИКТ

Внимательно прочитайте текст задания и выберите верный ответ из списка

Задание 8035

Ниже приведён фрагмент программы, записанный на четырёх языках программирования.

Массив A двумерный; в программе рассматривается его фрагмент, соответствующий значениям каждого индекса от 1 до 9.

 

Бейсик

Паскаль

FOR n=1 TO 9
FOR k=1 TO 9

A(n,k)=2*n+k
NEXT k
EXT n

for n:=1 to 9 do
  for k:=1 to 9 do
    A[n,k]:=2*n+k

Си

Алгоритмический язык

for (n=1;n<=9;n++)

  for (k=1;k<=9;k++)

    A[n][k]=2*n+k;

 

нц для n от 1 до 9
  нц для
k от 1 до 9
   
A[n,k]=2*n+k
  кц
кц

 

Сколько элементов указанного фрагмента массива A будут принимать нечётные значения после выполнения данного фрагмента программы?

 

Ответы:

45 - Правильный ответ
41
40
36
Грант-на-вуз
🎉
Выдаем гранты на обучение
Студент? Абитуриент? Школьник?
При регистрации на сервисе
тебя уже ждет гарантированный приз:
300 ₽
На заказ любой студенческой работы!