ЕГЭ Справочник

Введите ответ в поле ввода

Задание 7308

Ниже на четырёх языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b.  Укажите наименьшее из таких чисел x,  при вводе которых алгоритм печатает сначала 2, а потом 72.

 

Бейсик

Паскаль

DIM X, A, B AS INTEGER

INPUT X

A=0: B=1

WHILE X > 0

  A = A+1

  B = B*(X MOD 10)

  X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b: integer;

begin

  readln(x);

  a:=0; b:=1;

  while x>0 do

  begin

     a:=a+1;

     b:=b*(x mod 10);

     x:= x div 10

  end;

  writeln(a); write(b);

end.

Си

Алгоритмический

#include

void main()

{

  int x, a, b;

  scanf("%d", &x);

  a=0; b=1;

  while (x>0){

    a=a+1;

    b=b*(x%10);

    x= x/10;

  }

  printf("%d\n%d", a, b);

}

алг

нач

     цел x, a, b

     ввод x

     a:=0; b:=1

     нц пока x>0

         a:=a+1

         b:=b*mod(x,10)

         x:=div(x,10)

     кц

     вывод a, нс, b

кон

 

 

Решение:

89
Грант-на-вуз
Другие задачи на эту тему
Задание 7293 Задание 7303 Задание 7308 Задание 7314 Задание 7325 Задание 7335 Задание 7340 Задание 7346 Задание 7357 Задание 7367
🎉
Выдаем гранты на обучение
Студент? Абитуриент? Школьник?
При регистрации на сервисе
тебя уже ждет гарантированный приз:
300 ₽
На заказ любой студенческой работы!