ЕГЭ Справочник

Введите ответ в поле ввода

Задание 7466

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

Бейсик

Паскаль

DIM N, S AS INTEGER

N = 0

S = 301

WHILE S > 0

  S = S - 10

  N = N + 2

WEND

PRINT N

var n, s: integer;

begin

  n := 0;

  s := 301;

  while s > 0 do

  begin

    s := s - 10;

    n := n + 2

  end;

  write(n)

end.

Си

Алгоритмический

#include

void main()

{

  int n, s;

  n = 0;

  s = 301;

  while (s > 0)

  {

    s = s - 10;

    n = n + 2;

  }

  printf("%d", n);

}

алг

нач

  цел n, s

  n := 0

  s := 301

  нц пока s > 0

    s := s - 10

    n := n + 2

  кц

  вывод n

кон

 

Решение:

62
Грант-на-вуз
Другие задачи на эту тему
Задание 7304 Задание 7315 Задание 7336 Задание 7347 Задание 7368 Задание 7379 Задание 7400 Задание 7411 Задание 7432 Задание 7443
🎉
Выдаем гранты на обучение
Студент? Абитуриент? Школьник?
При регистрации на сервисе
тебя уже ждет гарантированный приз:
300 ₽
На заказ любой студенческой работы!