ЕГЭ Справочник

Введите ответ в поле ввода

Задание 8174

Ниже на пяти языках программирования записана рекурсивная функция (процедура) F.

Бейсик

Python

SUB F(n)

  PRINT n,

  IF n >= 5 THEN

    F(n - 2)

    F(n - 1)

    F(n - 2)

  END IF

END SUB

def F(n):

    print(n, end='')

    if n >= 5:

        F(n - 2)

        F(n - 1)

        F(n - 2)

 

Алгоритмический язык

Паскаль

алг F(цел n)

нач

  вывод n

  если n >= 5 то

    F(n - 2)

    F(n - 1)

    F(n - 2)

  все

кон

procedure F(n: integer);

begin

  write(n);

  if n >= 5 then

  begin

    F(n - 2);

    F(n - 1);

    F(n - 2)

  end

end;

Си

void F(int n) {

  printf("%d", n);

  if (n >= 5) {

    F(n - 2);

    F(n - 1);

    F(n - 2);

  }

}

Что выведет программа при вызове F(6)? В ответе запишите последовательность выведенных цифр слитно (без пробелов).

Решение:

6453434
Грант-на-вуз
Другие задачи на эту тему
Задание 7460 Задание 7467 Задание 7492 Задание 7499 Задание 7524 Задание 7531 Задание 7556 Задание 7563 Задание 7588 Задание 7595
🎉
Выдаем гранты на обучение
Студент? Абитуриент? Школьник?
При регистрации на сервисе
тебя уже ждет гарантированный приз:
300 ₽
На заказ любой студенческой работы!