ЕГЭ Справочник

Внимательно прочитайте текст задания и выберите верный ответ из списка

Задание 7492

В программе описаны одномерный целочисленный массив A с индексами
от 0 до 10 и целочисленные переменные i и t. Ниже представлен фрагмент этой программы, записанный на разных языках программирования.

 

Бейсик

Паскаль

FOR i = 0 TO 10

  A(i) = i

NEXT i

t = A(0)

FOR i = 1 TO 10

  A(i-1) = A(i)

NEXT i

A(10) = t

for i := 0 to 10 do

  A[i] := i;

t := A[0];

for i := 1 to 10 do

  A[i-1] := A[i];

A[10] := t;

Си

Алгоритмический

for (i = 0; i <= 10; i++)

  A[i] = i;

t = A[0];

for (i = 1; i <= 10; i++)

  A[i-1] = A[i];

A[10] = t;

нц для i от 0 до 10

  A[i] := i

кц

t := A[0]

нц для i от 1 до 10

  A[i-1] := A[i]

кц

A[10] := t

 

Чему окажутся равны элементы этого массива после выполнения фрагмента программы?

 

Ответы:

1 2 3 4 5 6 7 8 9 10 10  
1 2 3 4 5 6 7 8 9 10 0   - Правильный ответ
0 0 0 0 0 0 0 0 0 0 0  
10 10 10 10 10 10 10 10 10 10 0  
Грант-на-вуз
Другие задачи на эту тему
Задание 7300 Задание 7332 Задание 7364 Задание 7396 Задание 7428 Задание 7460 Задание 7492 Задание 7524 Задание 7556 Задание 7588
🎉
Выдаем гранты на обучение
Студент? Абитуриент? Школьник?
При регистрации на сервисе
тебя уже ждет гарантированный приз:
300 ₽
На заказ любой студенческой работы!