ЕГЭ Справочник

Внимательно прочитайте текст задания и выберите верный ответ из списка

Задание 7588

В программе описаны одномерный целочисленный массив A с индексами
от 0 до 9 и целочисленные переменные i и t. Ниже представлен фрагмент этой программы, записанный на разных языках программирования.

 

Бейсик

Паскаль

FOR i = 0 TO 9

  A(i) = i+1

NEXT i

t = A(9)

FOR i = 8 TO 0 STEP -1

  A(i+1) = A(i)

NEXT i

A(0) = t

for i := 0 to 9 do

  A[i] := i+1;

t := A[9];

for i := 8 downto 0 do

  A[i+1] := A[i];

A[0] := t;

Си

Алгоритмический

for (i = 0; i <= 9; i++)

  A[i] = i+1;

t = A[9];

for (i = 8; i >= 0; i--)

  A[i+1] = A[i];

A[0] = t;

нц для i от 0 до 9

  A[i] := i+1

кц

t := A[9]

нц для i от 8 до 0 шаг -1

  A[i+1] := A[i]

кц

A[0] := t

 

Чему окажутся равны элементы этого массива после выполнения фрагмента программы?

Ответы:

10 3 4 5 6 7 8 9 10 10  
10 1 2 3 4 5 6 7 8 9   - Правильный ответ
10 1 1 1 1 1 1 1 1 1  
10 10 10 10 10 10 10 10 10 10  
Грант-на-вуз
Другие задачи на эту тему
Задание 7300 Задание 7332 Задание 7364 Задание 7396 Задание 7428 Задание 7460 Задание 7492 Задание 7524 Задание 7556 Задание 7588
🎉
Выдаем гранты на обучение
Студент? Абитуриент? Школьник?
При регистрации на сервисе
тебя уже ждет гарантированный приз:
300 ₽
На заказ любой студенческой работы!