ЕГЭ Справочник

Внимательно прочитайте текст задания и выберите верный ответ из списка

Задание 7556

В программе описан одномерный целочисленный массив A с индексами
от 0 до 10. Ниже представлен фрагмент этой программы, записанный на разных языках программирования.

 

Бейсик

Паскаль

FOR i = 0 TO 10

  A(i) = i-1

NEXT i

FOR i = 1 TO 10

  A(i-1) = A(i)

NEXT i

A(10) = 10

for i := 0 to 10 do

  A[i] := i-1;

for i := 1 to 10 do

  A[i-1] := A[i];

A[10] := 10;

Си

Алгоритмический язык

for (i = 0; i <= 10; i++)

  A[i] = i-1;

for (i = 1; i <= 10; i++)

  A[i-1] = A[i];

A[10] = 10;

нц для i от 0 до 10

  A[i] := i-1

кц

нц для i от 1 до 10

  A[i-1] := A[i]

кц

A[10] := 10

 

Чему окажутся равны элементы этого массива после выполнения фрагмента программы?

Ответы:

0 1 2 3 4 5 6 7 8 9 10   - Правильный ответ
–1 –1 –1 –1 –1 –1 –1 –1 –1 –1 10  
1 2 3 4 5 6 7 8 9 10 10  
9 9 9 9 9 9 9 9 9 9 10  
Грант-на-вуз
Другие задачи на эту тему
Задание 7300 Задание 7332 Задание 7364 Задание 7396 Задание 7428 Задание 7460 Задание 7492 Задание 7524 Задание 7556 Задание 7588
🎉
Выдаем гранты на обучение
Студент? Абитуриент? Школьник?
При регистрации на сервисе
тебя уже ждет гарантированный приз:
300 ₽
На заказ любой студенческой работы!