ЕГЭ Справочник

Внимательно прочитайте текст задания и выберите верный ответ из списка

Задание 7332

В программе описан одномерный целочисленный массив A с индексами
от 0 до 10. Ниже представлен фрагмент одной и той же программы, записанный на разных языках программирования, в котором значения элементов сначала задаются, а затем меняются.

 

Бейсик

Паскаль

FOR i=0 TO 10

A(i)=i-1

NEXT i

FOR i=9 TO 0 STEP -1

A(i)=A(i+1)

NEXT i

for i:=0 to 10 do

  A[i]:=i-1;

for i:=9 downto 0 do

  A[i]:=A[i+1];

Си

Алгоритмический язык

for (i=0;i<=10;i++)

  A[i]=i-1;

for (i=9;i>=0;i--)

  A[i]=A[i+1];

нц для i от 0 до 10

  A[i]:=i-1

кц

нц для i от 9 до 0 шаг -1

  A[i]:=A[i+1]

кц

 

Как изменятся элементы этого массива после выполнения фрагмента программы?

Ответы:

все элементы, кроме последнего, будут сдвинуты на один элемент вправо
все элементы, кроме первого, будут сдвинуты на один элемент влево
все элементы окажутся равны своим индексам
все элементы окажутся равны 9 - Правильный ответ
Грант-на-вуз
Другие задачи на эту тему
Задание 7300 Задание 7332 Задание 7364 Задание 7396 Задание 7428 Задание 7460 Задание 7492 Задание 7524 Задание 7556 Задание 7588
🎉
Выдаем гранты на обучение
Студент? Абитуриент? Школьник?
При регистрации на сервисе
тебя уже ждет гарантированный приз:
300 ₽
На заказ любой студенческой работы!