ЕГЭ Справочник

Внимательно прочитайте текст задания и выберите верный ответ из списка

Задание 7428

В программе описан одномерный целочисленный массив A с индексами
от 0 до 10. Ниже представлен фрагмент этой программы, записанный на разных языках программирования, в котором значения элементов массива сначала задаются, а затем меняются.

 

Бейсик

Паскаль

FOR i=0 TO 10

A(i)=i+2

NEXT i

FOR i=1 TO 11

A(i-1)=A(11-i)

NEXT i

for i:=0 to 10 do

  A[i]:=i+2;

for i:=1 to 11 do

  A[i-1]:=A[11-i];

Си

Алгоритмический язык

for (i=0;i<=10;i++)

  A[i]=i+2;

for (i=1;i<=11;i++)

  A[i-1]=A[11-i];

нц для i от 0 до 10

  A[i]:=i+2

кц

нц для i от 1 до 11

  A[i-1]:=A[11-i]

кц

 

Чему окажутся равны элементы этого массива после выполнения фрагмента программы?

 

Ответы:

12 11 10 9 8 7 8 9 10 11 12 - Правильный ответ
11 10 9 8 7 6 7 8 9 10 11  
12 11 10 9 8 7 6 5 4 3 2  
11 10 9 8 7 6 5 4 3 2 1  
Грант-на-вуз
Другие задачи на эту тему
Задание 7300 Задание 7332 Задание 7364 Задание 7396 Задание 7428 Задание 7460 Задание 7492 Задание 7524 Задание 7556 Задание 7588
🎉
Выдаем гранты на обучение
Студент? Абитуриент? Школьник?
При регистрации на сервисе
тебя уже ждет гарантированный приз:
300 ₽
На заказ любой студенческой работы!