ЕГЭ Справочник

Внимательно прочитайте текст задания и выберите верный ответ из списка

Задание 7716

В программе используется одномерный целочисленный массив A
с индексами от 0 до 9. Значения элементов равны 7; 9; 5; 2; 1; 6; 0; 3; 4; 8 соответственно, т.е. A[0] = 7; A[1] = 9 и т.д.

Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

Бейсик

Паскаль

c = 0

FOR i = 1 TO 9

  IF A(i) < A(0) THEN

    c = c + 1

    t = A(i)

    A(i) = A(0)

    A(0) = t

  ENDIF

NEXT i

c := 0;

for i := 1 to 9 do

  if A[i] < A[0] then

  begin

    c := c + 1;

    t := A[i];

    A[i] := A[0];

    A[0] := t

  end;

Си

Алгоритмический язык

c = 0;

for (i = 1; i <= 9; i++)

  if (A[i] < A[0])

  {

    c++;

    t = A[i];

    A[i] = A[0];

    A[0] = t;

  }

c := 0

нц для i от 1 до 9

  если A[i] < A[0] то

    c := с + 1

    t := A[i]

    A[i] := A[0]

    A[0] := t

  все

кц

 

 

Ответы:

7
6
5
4 - Правильный ответ
Грант-на-вуз
Другие задачи на эту тему
Задание 7300 Задание 7332 Задание 7364 Задание 7396 Задание 7428 Задание 7460 Задание 7492 Задание 7524 Задание 7556 Задание 7588
🎉
Выдаем гранты на обучение
Студент? Абитуриент? Школьник?
При регистрации на сервисе
тебя уже ждет гарантированный приз:
300 ₽
На заказ любой студенческой работы!