ЕГЭ Справочник

Внимательно прочитайте текст задания и выберите верный ответ из списка

Задание 7780

В программе используется одномерный целочисленный массив A
с индексами от 0 до 9. Значения элементов равны 6; 9; 7; 2; 1; 5; 0; 3; 4; 8 соответственно, т.е. A[0] = 6; A[1] = 9 и т.д.

Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

Бейсик

Паскаль

c = 0

FOR i = 0 TO 8

  IF A(i) < A(i + 1) THEN

    c = c + 1

    t = A(i)

    A(i) = A(i + 1)

    A(i + 1) = t

  ENDIF

NEXT i

c := 0;

for i := 0 to 8 do

  if A[i] < A[i + 1] then

  begin

    c := c + 1;

    t := A[i];

    A[i] := A[i + 1];

    A[i + 1] := t

  end;

Си

Алгоритмический язык

c = 0;

for (i = 0; i <= 8; i++)

  if (A[i] < A[i + 1])

  {

    c++;

    t = A[i];

    A[i] = A[i + 1];

    A[i + 1] = t;

  }

c := 0

нц для i от 0 до 8

  если A[i] < A[i + 1] то

    c := с + 1

    t := A[i]

    A[i] := A[i + 1]

    A[i + 1] := t

  все

кц

 

 

Ответы:

8
7
6 - Правильный ответ
5
Грант-на-вуз
Другие задачи на эту тему
Задание 7300 Задание 7332 Задание 7364 Задание 7396 Задание 7428 Задание 7460 Задание 7492 Задание 7524 Задание 7556 Задание 7588
🎉
Выдаем гранты на обучение
Студент? Абитуриент? Школьник?
При регистрации на сервисе
тебя уже ждет гарантированный приз:
300 ₽
На заказ любой студенческой работы!