ЕГЭ Справочник

Внимательно прочитайте текст задания и выберите верный ответ из списка

Задание 7971

Значения элементов двух массивов – A и B – с индексами от 1 до 500 задаются с помощью следующего фрагмента программы.

 

Бейсик

Паскаль

FOR n=1 TO 500

A(n)=100-n

NEXT n

FOR n=1 TO 500

B(n)=2*A(501-n)

NEXT n

for n:= 1 to 500 do

    A[n] := 100-n;

for n:= 1 to 500 do

    B[n] := 2*A[501-n];

Си

Алгоритмический язык

for (n=1;n<=500;n++)

  A[n]=100-n;

for (n=1;n<=500;n++)

  B[n]=2*A[501-n];

нц для n от 1 до 500

    A[n] := 100-n

кц

нц для n от 1 до 500

    B[n] := 2*A[501-n]

кц

 

 

Сколько элементов массива B будут иметь положительные значения после выполнения фрагмента программы?

 

Ответы:

401
400
100
99 - Правильный ответ
Грант-на-вуз
Другие задачи на эту тему
Задание 7300 Задание 7332 Задание 7364 Задание 7396 Задание 7428 Задание 7460 Задание 7492 Задание 7524 Задание 7556 Задание 7588
🎉
Выдаем гранты на обучение
Студент? Абитуриент? Школьник?
При регистрации на сервисе
тебя уже ждет гарантированный приз:
300 ₽
На заказ любой студенческой работы!